online kép - Fájl  tubefájl feltöltés file feltöltés - adja hozzá a fájlokat onlinefedezze fel a legújabb online dokumentumokKapcsolat
  
 

Letöltheto dokumentumok, programok, törvények, tervezetek, javaslatok, egyéb hasznos információk, receptek - Fájl kiterjesztések - fajltube.com

 

Online dokumentumok - kep
  

Elemi programozasi tétele XI.: rendezés buborékos módszerrel

számítógépes

Fájl küldése e-mail



egyéb tételek

 
Programozható vezérlők hardverfelépítése
A Debian GNU/Linux operaciós rendszer konfiguralasa
A VOIP TECHNOLÓGIA ÁTTEKINTÉSE
NOVELL NETWARE jellemzői
A WINDOWS 3x és a WINDOWS 9x rendszerek
Szamítógép generaciók
Munkadarab (alkatrész, gyartmany)
Vírusprogramok
Egyszerű web szerver készítése
 
 

Elemi programozási tétele XI.: rendezés buborékos módszerrel




A buborékos rendezés ala 656b16g pgondolata a szomszédos elemek cseréje. Az első menetben a rendező A vektor végéről indulva minden elemet összehasonlítunk az előtte lévővel. Amennyiben rossz sorrendben vannak, felcseréljük őket. Az első menet végére a legkisebb elem biztosan a helyére kerül. Minden további menetben ismét a vektor végéről indulunk, de egyre kevesebb hasonlításra van szükségünk, mert a vektor eleje fokozatosan rendezetté válik.


Algoritmus:


Eljárás

Ciklus I=2-től N-ig

Ciklus J=N-től I-ig -1-esével

Ha A(J-1)>A(J) akkor A:=A(J-1)

A(J-1):=A(J)

A(J):=A

Elágazás vége

Ciklus vége

Ciklus vége

Eljárás vége.

Találat: 1256